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This documentation presents information specific to Nexenta products. The information is for reference 
purposes and is subject to change.

Intended Audience

This documentation is intended for Network Storage Administrators and assumes that you have experience 
with data storage concepts, such as iSCSI, FC, NFS, SMB, and High Availability.

Documentation History

The following table lists the released revisions of this documentation.

Contacting Support

Choose a method for contacting support:

• Visit the Nexenta customer portal http://nexenta.force.com/customerportal or partner portal http://
nexenta.force.com/partnerportal. Log in and browse a knowledge base.

Comments

Your comments and suggestions to improve this documentation are greatly appreciated. Send any feedback 
to doc.comments@nexenta.com and include the documentation title, number, and revision. Refer to 
specific pages, sections, and paragraphs whenever possible.

Product Versions Applicable to this Documentation:Documentation Revision History

Revision Date Description

3000-vc_plug-1.0-000048-A October, 2014 GA
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1
Introduction to NexentaStor vCenter Web

Client Plugin
This section includes the following topics: 

•  About NexentaStor vCenter Web Client Plugin

•  Browser Compatibility

About NexentaStor vCenter Web Client Plugin

NexentaStor vCenter Web Client Plugin, aka Web Client Plugin, is an extension to the VMware vSphere 
that enables management of the NexentaStor NFS folders and iSCSI LUNs as datastores in the VMware 
vSphere Web Client. 

NexentaStor vCenter Web Client Plugin provides the following features available through the VMware 
vSphere Web Client:

• Provisioning of NexentaStor LUNs as NFS and iSCSI datastores

• Capability to create a single snapshot and a snapshot schedule for a NexentaStor datastore

• Reverting NexentaStor datastores to the snapshots created using the NexentaStor vCenter Web 
Client Plugin

• Cloning from a snapshot 

• Monitoring the NexentaStor datastores I/O statistics

See Also:

•  Browser Compatibility

Browser Compatibility

NexentaStor vCenter Web Client Plugin supports the following web-browsers:

• Microsoft Internet ExplorerTM 8, 9 (64-bit), and 10.

• Mozilla FirefoxTM 24or later.

• Google ChromeTM 30 or later.

See Also:

•  About NexentaStor vCenter Web Client Plugin

Note: Adobe Flash PlayerTM 11.5.0 or later must be installed in your web-browser.
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Installing NexentaStor vCenter Web Client

Plugin
This chapter includes the following topics:

•  Prerequisites

•  Installing NexentaStor vCenter Web Client Plugin

•  Uninstalling NexentaStor vCenter Web Client Plugin

Prerequisites

Before installing NexentaStor vCenter Web Client Plugin, verify that your environment includes the 
following components:

• NexentaStor 4.x.

You must create at least one volume that you will use as datastore to provision NFS folders or iSCSI 
LUNs.

• Microsoft Windows Server 2003/2008 R2 with VMware vSphereTM 5.1/5.5

Java Runtime Environment (JRE)TM v1.7 must be installed.

• VMware vCenter Server 5.1/5.5 and Web ClientTM 5.1/5.5

See Also:

•  NexentaStor Installation Guide

•  VMware vSphere 5.1 Documentation Center 

•  Browser Compatibility

Configuring vSphere Web Client

To make vSphere Web Client work correctly you must modify the webclient.properties file. 

 To configure vSphere Web Client:

1. Go to C:\ProgramData\VMware\vSphere Web Client.

2. Open the webclient.properties file in any source code editor, such as Notepad. 

3. Add the following line to the file: 

HTTP.DOWNLOAD=true
allowHttp=true

http://pubs.vmware.com/vsphere-51/index.jsp
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4. Save the file.

Installing NexentaStor vCenter Web Client Plugin

Install NexentaStor vCenter Web Client Plugin on Microsoft Windows Server, on which the vSphere server 
is installed, using the Web Client Plugin installation file. 

 To install the NexentaStor vCenter Web Client Plugin:

1. From the Nexenta web-site, download the NexentaStor vCenter Web Client Plugin archive.

2. Log in to the Microsoft Windows Server where the vCenter Server is installed.

3. Upload the NexentaStor vCenter Web Client Plugin archive to Microsoft Windows Server.

4. Run the Web Client Plugin installer file. 

The Windows Installation Wizard starts.

5. Click Next.

6. Read and verify the environment prerequisites.

7. Accept the terms of License Agreement; then click Next.

8. Verify the installation folder; then click Next.

9. Type the vCenter credentials and press Next.

The plugin is now registered as vCenter Managed Object Browser (MOB).

10. Click Next.

11. Click Install.

The Web Client Plugin is being installed. It may take some time.

12. Click Finish.

13. Extract the Nexenta.zip to C:\Program 
Files\VMware\Infrastructure\vSphereWebClient\plugin-
packages\nexenta. 

The Nexenta.zip file is located in the plugin installation folder.

14. Copy the vgs.properties file to C:\Program 
Files\VMware\Infrastructure\vSphereWebClient\server.

15. Restart the VMware vSphere web client service:

1.In Windows Server, click Start > Services.

2.In the list of Services, right-click on the VMware vSphere Web Client.

3.Select Restart.

Note:
You can discard the changes after the Web Client Plugin icon appears in the VMware 
Web Client.
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16. Proceed to Basic System Operations.

Uninstalling NexentaStor vCenter Web Client Plugin

You uninstall NexentaStor vCenter Web Client Plugin by running the plugin Microsoft installer file and 
following the prompts. You cannot uninstall the plugin using Microsoft Windows uninstall tool.
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3
Basic System Operations

This section includes the following topics: 

•  About Managing NexentaStor vCenter Web Client Plugin

•  Adding NexentaStor Configuration to VMware vSphere

•  Modifying NexentaStor Configuration

•  Deleting a NexentaStor Configuration

•  Adding a VMware vCenter Configuration

•  Adding a NexentaStor Datastore

•  Viewing the NexentaStor Datastore Summary

About Managing NexentaStor vCenter Web Client Plugin 

You manage NexentaStor vCenter Web Client Plugin using VMware vSphere Web Client. After Installation, 
click the Home tab and select the Nexenta Config icon. 

The following screenshot shows the NexentaStor vCenter Web Client Plugin initial configuration icon in 
VMware vSphere Web Client:

Figure 3-1:  NexentaStor vCenter Web Client Plugin
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Adding NexentaStor Configuration to VMware vSphere

Before you can view details about NexentaStor, you must add the NexentaStor configuration file to 
VMware vSphere. 

 To add a NexentaStor configuration to VMware vSphere, using VMware vSphere Web Client:

1. Click the Home tab. 

2. Select the Nexenta Config icon.

3. In the Nexenta Config tab, click Add Nexenta Config.

4. Select a protocol from the list:

• HTTPS

• HTTP

5. Type the NexentaStor IP address.

6. Type the NexentaStor Web UI port number.

Default port number for NexentaStor 4.x is 8457.

7. Type NexentaStor user and password.

8. Click Create.

Modifying NexentaStor Configuration

When you change NexentaStor parameters, such as IP address, port number, protocol, or credentials, you 
must update the NexentaStor vCenter Web Client Plugin configuration.

 To modify NexentaStor configuration, using VMware vSphere Web Client:

1. Click the Home tab. 

2. Select the Nexenta Config icon.

3. In the Action column, click the Update Nexenta Config icon.

4. Modify the required parameters. 

5. Click Update.

Note: Type the IP address used for NFS or iSCSI.

Note: The NexentaStor user must have privileges to execute REST API requests.
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Deleting a NexentaStor Configuration

You can delete unused NexentaStor configurations. 

 To delete a NexentaStor configuration, using VMware vSphere Web Client:

1. Click the Home tab. 

2. Select the Nexenta Config icon.

3. In the Action column, click the Delete Nexenta Config icon.

4. In the confirmation dialog window, click Delete. 

Adding a VMware vCenter Configuration

You must add a link to the SDK of the VMware vSphere that you use, so it can communicate with the 
NexentaStor RESTful API through the NexentaStor vCenter Web Client Plugin.

You cannot delete VMware vSphere configurations.

 To add a VMware vCenter configuration, using VMware vSphere Web Client:

1. Click the Home tab. 

2. Select the Nexenta Config icon.

3. Select VMware Config.

4. In the VMware Config tab, click Add VMare Config.

5. Select a protocol:

• HTTPS

• HTTP

6. Type the VMware vCenter IP address.

7. Type the VMware vSphere credentials .
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Adding a NexentaStor Datastore

You can add a NexentaStor NFS or iSCSI datastore. To provision a NexentaStor datastore, create a volume 
on the NexentaStor appliance for iSCSI datastore or a folder for NFS datastore.

 To add a NexentaStor datastore, using VMware vSphere Web Client: 

1. Click Home > Hosts and Clusters.

2. Right-click on an ESXi host on which you want to create the datastore. 

3. Select All NexentaStor vCenter Web Client Plugin Actions > Create Nexenta Datastore. 

4. In the Create Datastore window, specify:

Datastore Type Select NFS Datastore for NFS or SAN Datastore for NexentaStor zvols 
provisioned through iSCSI.
You must create a volume on the NexentaStor appliance before you can 
provision them as datastores for SAN Volume.

Host An IP address of the VMware ESXi host on which the plugin creates the 
NexentaStor datastore.

Nexenta Host The IP address of the NexentaStor appliance from which you want to 
provision the datastore.
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5. Click Create. 

Viewing the NexentaStor Datastore Summary

After you add a NexentaStor datastore to VMware vSphere Server, you can view information about this 
datastore in Summary Information.

 To view the NexentaStor Datastore Summary, using VMware vSphere Web Client: 

1. Click Home > Hosts and Clusters.

2. Double-click on VMware ESXi on which you created the NexentaStor datastore. 

3. Click the Storage icon.

4. Select the NexentaStor datastore.

Datastore Name Descriptive name of the datastore. 

Group Name (SAN Datastore only) Name of the Target Group on the NexentaStor 
appliance. You can create a new group using this field. 

Volume/Folder A dataset that you want to provision as datastore. Select a folder for NFS 
folder and volume for SAN Volume.

Quota (NAS Datastore only) Amount of space that users can use in the folder. 
Type 0 for None. 

Disk size Allocate disk size for this datastore. 

Block Size (SAN Datastore only) Size of blocks for files in a dataset. 

Record Size (NAS Datastore only) A data unit that is used in copy-on-write 
mechanism. 

Compression Type of compression:
• on 
• off
• gzip 1 — 9

Sync Setting for synchronous requests: 
• Standard — synchronous requests are written to the intent log and 

all devices are flushed. No caching.
• Always — every file system transaction is flushed to the stable 

storage. Using this option may have negative impact to the datastore 
performance.

• Disabled — file system transactions are written to the stable storage 
with the next DMU transaction. Using this option provides the 
highest performance, however, it may result in data loss. 



  

12
Copyright © 2014 Nexenta Systems, ALL RIGHTS RESERVED
www.nexenta.com

NexentaStor vCenter Web Client Plugin Installation and Administration Guide

The following information is displayed for the NexentaStor datastore: 
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4
Deploying Linux Version

This section includes the following topics: 

•  About Linux Virtual Appliance

•  Deploying the vCenter Server Linux Virtual Appliance

•  Setting the vCenter Server Linux Virtual Appliance

•  Configuring Basic Settings

•  Installing NexentaStor vCenter Web Client Plugin on VMware vCenter Server Linux Virtual 
Appliance

•  Uninstalling NexentaStor vCenter Web Client Plugin from VCVA

About Linux Virtual Appliance

The VMware vCenter Server Linux Virtual Appliance (VCSA) is a pre-installed virtual machine that provides 
vCenter Server and associated services. 

You must have the following components pre-installed:

• VMware vSphere 5.1 or later

You deploy VCSA on VMware ESXi. Therefore, you must have VMware vSphere 5.1 or later installed in 
your environment

• Java SE Runtime Environment 7 must be installed and set in the PATH system variable and 
environment variable on vCenter Virtual Appliance

Deploying the vCenter Server Linux Virtual Appliance 

You deploy the vCenter Server Linux Virtual Appliance using the .ovf template.

 To deploy the vCenter Server Linux Virtual Appliance, using vSphere Client:

1. Click File > Deploy OVF Template.

2. Select the VCSA .ovf file.

3. Click Open.

4. Skip to Name and Location.

5. Type the name of the appliance.

6. Click Next.
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7. Select a datastore on which to deploy the appliance.

8. Click Next.

9. Select Disk Format.

10. Click Next.

11. Review the settings and click Finish. 

The deployment starts.

Setting the vCenter Server Linux Virtual Appliance

After you install the VCSA, you must configure some of appliance parameters. 

 To set the vCenter Server Linux Virtual Appliance:

1. In vSphere Client, start the VCSA.

2. Select the VCSA and click the Console tab. 

3. Configure network and time zone parameters.

4. Remember the IP address of the appliance.

5. Open a browser. 

6. Type the address of the VCSA and port number.

Example:

https://<ip_of_vcsa:5480>

7. Then prompted, accept the certificate security message.

8. Type root credentials.

Default password is vmware.

9. Read and accept the terms of End User License Agreement.

vCenter configuration starts. It may take some time.

Monitor the progress in the vSphere Console.

10. Proceed to Configuring Basic Settings.

Configuring Basic Settings

You must complete tasks in Deploying the vCenter Server Linux Virtual Appliance and Setting the vCenter 
Server Linux Virtual Appliance before you can configure basic settings.

After console displays the default screen, continue configuring the appliance.
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 To configure basic settings:

1. Log in to the VCSA:

1. Open a browser and type the IP address of VCSA with port number.

Example:

https://<ip_of_vcsa:5480>

2. Type root credentials.

3. Configure Network settings

1. Click the Network tab.

2. Click Address.

3. Modify hostname and other parameters as needed. 

4. Click Save Settings.

4. Configure Authenticatio settings:

1. Click vCenter Server > Authentication.

2. Configure the Active Directory settings as needed. 

3. Click Save Settings

5. Configuring Database

You can use an existing database or embedded vCenter database. If you use an existing 
database, you must know the database information, such as database server IP address and 
so on. 

1. Click the Database tab.

2. Select the type of the database: 

•  Embedded

•  Oracle

3. If you selected Embedded database, do not enter any details. Instead, click Test Settings.

4. This operation may take some time.

5. If you selected Oracle, fill in the corresponding fields.

6. Click Save Settings. 

6. Reboot the VCSA:

1. Select the System tab.

2. Click Reboot.

After the reboot, VCSA initiates the database and the vpxd daemon.
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Installing NexentaStor vCenter Web Client Plugin on 
VMware vCenter Server Linux Virtual Appliance 

After you complete the tasks described in Deploying the vCenter Server Linux Virtual Appliance,Setting 
the vCenter Server Linux Virtual Appliance, and Configuring Basic Settings, install NexentaStor vCenter 
Web Client Plugin on the VCVA.

 To install NexentaStor vCenter Web Client Plugin on VCVA:

1. Log in to the VCVA console. 

2. Back up the /var/lib/vmware/vsphere-client/webclient.properties: 

# cp /var/lib/vmware/vsphere-client/webclient.properties /var/lib/ 
vmware/vsphere-client/webclient.properties.src 

3. Open the webclient.properties file for editing: 

# vi /var/lib/vmware/vsphere-client/webclient.properties 

4. Add the following lines to the file: 

HTTP.DOWNLOAD=true 

allowHttp=true 

5. Save the file: 

:wq! 

6. Copy the NexentaPlugin.zip file to the /opt directory.

7. Extract the plugin from the NexentaPlugin.zip archive to the /opt directory:

# unzip /opt/NexentaPlugin.zip -d /opt

8. From the plugin folder, execute the install.bash file:

# bash /opt/NexentaPlugin /install.bash

The plugin is being installed and registered. 

9. Log in to VCVA GUI. 

10. Restart the vSphere web-client service.

Starting and Stopping the NexentaStor vCenter Web Client Plugin Service

You may need to start or stop the NexentaStor vCenter Web Client Plugin service. 

 To start the plugin service:

1. Type:

# service nexenta-service start

 To stop the plugin service: 

1. Type:
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# service nexenta-service stop

Uninstalling NexentaStor vCenter Web Client Plugin from 
VCVA

You can uninstall NexentaStor vCenter Web Client Plugin from VCVA anytime after installation. You will 
not be able to add new NexentaStor datastores to VMware vCenter after that. 

 To uninstall NexentaStor vCenter Web Client Plugin from VCVA:

1. Type:

# bash /opt/NexentaPlugin/uninstall.bash
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5
Additional System Operations

This section includes the following topics: 

•  About Datastore Monitoring

•  Monitoring NexentaStor Datastores using Web Client Plugin

•  About Datastore Snapshot Management

•  Viewing the List of Datastore Snapshots

•  Creating a Datastore Snapshot

•  Cloning a Volume from a Datastore Snapshot

•  Restoring a Datastore Snapshot

•  Deleting a Datastore Snapshot

•  Viewing the list of Snapshot Services

•  Creating a Snapshot Service

•  Enabling a Snapshot Service

•  Disabling a Snapshot Service

•  Deleting a Snapshot Service

About Datastore Monitoring

Monitoring the performance of datastores is an important part of network and storage analysis that assist 
in determining and eliminating bandwidth issues. Typically, datastore performance is evaluated in number 
of read and write operations per second, aka Input/Output operations per second (IOPS). 

NexentaStor vCenter Web Client Plugin enables you to monitor the NexentaStor datastore performance in 
the VMware vSphere Web Client. 

NexentaStor vCenter Web Client Plugin collects and displays the following NexentaStor performance 
statistics in the VMware vSphere Web Client:

• Disk I/O 

• Average Disk I/O 

See Also:

•  Monitoring NexentaStor Datastores using Web Client Plugin
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Monitoring NexentaStor Datastores using Web Client 
Plugin

NexentaStor vCenter Web Client Plugin displays additional information for the NexentaStor datastore. You 
can monitor datastore statistics after you add a NexentaStor NFS or iSCSI datastore. 

 To monitor the NexentaStor Datastore, using the VMware vSphere Web Client:

1. Click Home > Hosts and Clusters.

2. Click the Storage icon.

3. Select a NexentaStor datastore.

4. Click Monitor > Storage Monitoring.

Figure 5-1:  Example of a Disk I/O Graph

Note:
Verify that time is synced between NexentaStor and VMware vCenter. Otherwise, 
the monitoring data is not available.
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Figure 5-2:  Example of a Average I/O Graph

See Also:

•  About Datastore Monitoring

About Datastore Snapshot Management

NexentaStor vCenter Web Client Plugin provides the capability to create snapshot and snapshot services 
for the NexentaStor datastores in VMware vSphere Web Client. 

NexentaStor datastore snapshot is a read-only point-in-time representation of a NexentaStor NFS or iSCSI 
datastore. You can clone a datastore snapshot to create an editable copy. Almost unlimited number of 
snapshots can be created. Snapshots are stored with the source dataset.

You can perform the following actions with datastore snapshots:

• Clone a volume from a datastore snapshot

• Revert the state of a datastore and all files on that datastore to the selected snapshot

• Delete a snapshot

See Also:

•  Viewing the List of Datastore Snapshots

•  Creating a Datastore Snapshot

Viewing the List of Datastore Snapshots

NexentaStor datastore snapshots are listed under the DataStore Snapshots tab.

 To view the list of snapshots, using the VMware vSphere Web Client:

1. Click Home > Hosts and Clusters.



  

22
Copyright © 2014 Nexenta Systems, ALL RIGHTS RESERVED
www.nexenta.com

NexentaStor vCenter Web Client Plugin Installation and Administration Guide

2. Click the Storage icon.

3. Select Manage > Datastore Snapshots.

See Also:

•  Creating a Datastore Snapshot

•  Creating a Snapshot Service

Creating a Datastore Snapshot

You can create a point-in-time representation of a NexentaStor datastore, aka snapshot to preserve the 
state of the datastore. You can later roll back the NexentaStor datastore to this state or create a new 
volume from that snapshot.

 To create a datastore snapshot, using the VMware vSphere Web Client:

1. Click Home > Hosts and Clusters.

2. Click the Storage icon.

3. Select Manage > Datastore Snapshots.

4. Click Create Snapshot.

5. Type the snapshot name.

Optionally, select the checkbox to snapshot only the parent folder not including nested 
folders into the snapshot. 

6. Click Create.

See Also:

•  Cloning a Volume from a Datastore Snapshot

•  Creating a Snapshot Service

Cloning a Volume from a Datastore Snapshot

You can clone a datastore volume or a folder from a snapshot and use it as an independent datastore. 

 To clone a volume from a datastore snapshot, using the VMware vSphere Web Client:

1. Click Home > Hosts and Clusters.

2. Click the Storage icon.

3. Select Manage > Datastore Snapshots.

4. In the Action column, click Clone Volume from Snapshot.

Note:
After you create a clone of a snapshot, you will be no longer able to delete the 
snapshot.
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5. Type the Clone Name.

6. Select a volume or a folder.

7. Optionally, select an ESXi server on which you want to share the datastore. 

8. Click Create Clone.

The clone of the folder/volume appears as a datastore under Storage of the selected ESXi 
server. You can create snapshots and snapshot services for this datastore. 

See Also:

•  Restoring a Datastore Snapshot

•  Deleting a Datastore Snapshot

Restoring a Datastore Snapshot

You can restore the data in a NexentaStor datastore to the state captured at the moment of a snapshot 
creation. 

When you restore a snapshot, you can select from the following destroy options:

• Destroy more recent snapshots and nested snapshots

• Destroy more recent snapshots and clones

• Destroy and unmount cloned folders that you are destroying

 To restore a datastore snapshot, using the VMware vSphere Web Client:

1. Click Home > Hosts and Clusters.

2. Click the Storage icon.

3. Select Manage > Datastore Snapshots.

4. In the Action column, click Restore Snapshot.

5. Select a destroy option. 

6. Click Restore. 

See Also:

•  Deleting a Datastore Snapshot

•  Cloning a Volume from a Datastore Snapshot

Deleting a Datastore Snapshot

You can delete unused snapshots. Before you can delete a snapshot, you must unshare the NexentaStor 
zvol for which. 

Use care when you delete snapshots. You cannot restore snapshots after deletion. 
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When you delete a snapshot, you can choose from the following options: 

• Delete the snapshot

• Delete the snapshot and its clones

• Delete the snapshot and unmount its clones

 To delete a datastore snapshot, using the VMware vSphere Web Client:

1. Click Home > Hosts and Clusters.

2. Click the Storage icon.

3. Select Manage > Datastore Snapshots.

4. In the Action column, click Destroy Snapshot.

5. Select a destroy option. 

See Also:

•  Cloning a Volume from a Datastore Snapshot

•  Restoring a Datastore Snapshot

Viewing the list of Snapshot Services

The list of snapshot services is displayed under the Scheduled Task tab in the VMware vSphere Web 
Client.

 To view the list of snapshot services:

1. Click Home > Hosts and Clusters.

2. Click the Storage icon.

3. Select Manage > Scheduled Snapshots.

See Also:

•  Creating a Snapshot Service

•  Enabling a Snapshot Service

Creating a Snapshot Service

You can create an automatic periodic snapshot service for a NexentaStor datastore. You can create 
multiple Auto-Snap services with a unique schedule for each datastore. The service automatically creates 
a point-in-time representation of a datastore on a regular basis (monthly, weekly, daily, hourly, minute), 
creates snapshots of the root folder and its descendants, assists in creating a retention policy (Keep days).

Note: You can only delete snapshots that do not have clones.
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 To create a snapshot service:

1. Click Home > Hosts and Clusters.

2. Click the Storage icon.

3. Select Manage > Schedule Snapshots.

4. Click Create Schedule.

5. Fill the following fields:

6. Click Create.

See Also:

•  Enabling a Snapshot Service

•  Deleting a Snapshot Service

Enabling a Snapshot Service

When you create a snapshot service, it is disabled by default. To start the service, you must first enable it. 

 To enable a snapshot service:

1. Click Home > Hosts and Clusters.

2. Click the Storage icon.

3. Select Manage > Schedule Snapshots.

4. In the Actions column, slide the runner to On.

5. In the confirmation dialog window, click OK.

See Also:

•  Disabling a Snapshot Service

•  Deleting a Snapshot Service

Name Snapshot schedule name.

Keep Days Retention policy. Number of days to keep snapshots.

Periodic Interval Select from the following options: 
• Minute
• Hourly
• Daily
• Weekly
• Monthly
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Disabling a Snapshot Service

You can temporary disable snapshot services. When you disable a service, it stops creating snapshots for 
the selected dataset at scheduled period. 

 To disable a snapshot service:

1. Click Home > Hosts and Clusters.

2. Click the Storage icon.

3. Select Manage > Schedule Snapshots.

4. In the Actions column, slide the runner to Off.

5. In the confirmation dialog window, click OK.

See Also:

•  Enabling a Snapshot Service

•  Deleting a Snapshot Service

Deleting a Snapshot Service

You can delete the snapshot services that are no longer in use. When you delete a snapshot service, the 
information about the service is deleted from VMware vSphere. The snapshots created by this service are 
not deleted. 

 To delete a snapshot service:

1. Click Home > Hosts and Clusters.

2. Click the Storage icon.

3. Select Manage > Schedule Snapshots.

4. In the Actions column, click Delete Snapshot Schedule.

5. In the confirmation dialog window, click OK.

See Also:

•  Enabling a Snapshot Service

•  Disabling a Snapshot Service
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6
Troubleshooting NexentaStor vCenter Web

Client Plugin
This section includes the following topics: 

•  The Nexenta Config icon Is Not Displayed in vSphere Web Client

•  NexentaStor vCenter Web Client Plugin does not register in VMware vCenter Server

The Nexenta Config icon Is Not Displayed in vSphere Web 
Client

If the Nexenta Config icon is not displayed in vSphere Web Client, you must manually register the 
NexentaStor vCenter Web Client Plugin as a Windows Server service. 

 To register NexentaStor vCenter Web Client Plugin in Microsoft Windows Server:

1. Verify that you have added the following lines to the webclient.properties file: 

HTTP.DOWNLOAD=true
allowHttp=true

2. Extract the Nexenta.zip to C:\Program 
Files\VMware\Infrastructure\vSphereWebClient\plugin-packages\nexenta. 

3. Copy the vgs.properties file to C:\Program 
Files\VMware\Infrastructure\vSphereWebClient\server.

4. Restart the VMware vSphere web client service:

1.In Windows Server, click Start > Services.

2.In the list of Services, right-click on the VMware vSphere Web Client.

3.Select Restart.

NexentaStor vCenter Web Client Plugin does not register 
in VMware vCenter Server

If NexentaStor vCenter Web Client Plugin registration, fails you must first un-register and then re-install 
the plugin. 

Warning: Do not attempt to re-install the plugin before un-registering it.
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 To un-register and re-install the Web Client Plugin:

1. In a web-browser, log in to vCenter MOB as vCenter Administrator:

https://<hostname.yourcompany.com>/mob

2. Click on content > Extension Manager > Unregister Extension.

3. In the value box, type the plugin key as:

"com.acme.vitallabs.Vitallabs"

4. Click Invoke Method.

If the plugin was successfully unregistered, you should receive an empty response.

5. Log in to VCVA command line.

6. Change the directory to the plugin installation directory.

Default is C:\Program Files\Nexenta vCenter Web Clinet Plugin.

7. Run the following command:

java -jar Register-vCenterPlugin.jar --unregister

While un-registering the plugin, the VMware Virtual vCenter Server and Nexenta 
Virtualization Storage Management System service must be up and running.
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